[solved] Repositories always show Quick Guide - unrelated to #2665


#1
  • Gitea version: gitea-1.3.2-linux-arm-7
  • Git version: 2.1.4
  • Operating system: Debian 8.0
  • Database (use [x]):
    • PostgreSQL
    • MySQL
    • MSSQL
    • SQLite [x]
  • Can you reproduce the bug at https://try.gitea.io:
    • Yes (provide example URL)
    • No
    • Not relevant [x]
  • Log gist:

Description
I’ve installed gitea according to
https://canox.net/2017/12/raspberry-pi-gitea-installieren/
on my raspberry model 3 but I find that the Quick Guide shows in the web interface regardless of the commits. I’ve checked that the commits are indeed there. The repositories (under /home/git/gitea-repositories) are not mounted on a different file system.

I’ve tried to manually run the

Resync pre-receive, update and post-receive hooks of all repositories.

Reinitialize all missing Git repositories for which records exist

Synchronize external user data

but to no avail. How can I solve the problem of a non-updating Code
page? Thank you in advance.


#2

Hey there,

could you try creating a repository and ticking the Initialize this repository with selected files and template option at the bottom of the repo creation form? And then try to push something to the repos? Also, could you please enable logging in your custom/conf/app.ini? Should be a simple

MODE = console
LEVEL = Debug

in the [log] section.


#3

Yeah, that was it.

Since I have an existing repo, I first have to git pull --allow-unrelated-histories because otherwise I get fatal: refusing to merge unrelated histories. Only then can I run git push origin master.

Thanks for your help.


#4

How is this considered solved?
I noticed that if I initialize a repo with the readme it works. But that’s now what I and the OP was trying to do. We were trying to create an empty repo to push existing code. And that does not get rid of the Quick Guide. Having a workaround (that implied destroying the empty repo and never use the create empty repo function) is not “solved”.
How can I help in troubleshooting?


#5

For whoever stumbles into this, the bug is still open and discussed here https://github.com/go-gitea/gitea/issues/2898


#6

@signaleleven there is a similar bug to the one that this user had which is why this was marked as solved. You may be experiencing this one: https://github.com/go-gitea/gitea/issues/4424

I’m going to lock this thread as the user who opened this has had their issue solved. Please feel free to add input into the linked issue.


#7