Sign In Prohibited

Sign In Prohibited

Your account is prohibited to sign in, please contact your site administrator.

HI,
I’m a bit mystified why I am all of a sudden getting this message when trying to log in. As far as I am aware I am authenticated correctly (ie. if I type an incorrect password I get a Username or password is incorrect. message). This via LDAP or local.
In my postgres db prohibit_login is set to false in the user table. Is there anywhere else I should be looking ?

Many Regards

Gitea Version: 1.13.0+dev-344-g4315e313d

1 Like

Hey I’m getting this too, interestingly enough. I’m using LDAP auth, and it obviously authenticates me because it shows who I am and actually signs me in. I haven’t changed anything since it worked last. At least that I know of.

Is there any way to recover login access, even if it’s by creating a new user that has admin or something manually?

So I’m messing around with the database trying to figure out how to unlock the accounts and so far the only thing I’ve noticed is that if you set prohibit_login on the user in the user table, it will actually stop you from logging in, but the symptom that I notice right now is that you do login, it gets your avatar and your theme preferences even, but it doesn’t let you navigate to any pages without showing the prohibited page.

I’m using Gitea 1.9.

Hey @hwg I just fixed it. :slight_smile:

Somehow it appears that all of the user accounts were deactivated. If you check the is_active column in the database it is probably 0. Just set that to 1 and it works. Now I’m not sure how the accounts ended up in this state, though. :confused: That’s a little concerning.

On my Sqlite database I just ran:

update users set is_active = 1;

That’s assuming you want to activate every user account.

Yeah that fixed it for me. I saw the is_active field before and was sure I’d changed it but can only assume I did not commit it. Still I have no idea what deactivated the account. It had happened to one other account as well. Seems pretty random. Thanks for following up with this, saved me some grief.

1 Like

Strangely it happened to all of my accounts. I’m completely clueless of what caused it. Something to keep an eye on.

It has randomly happened to me again. No idea what has has triggered this. I hadn’t looked at it for a few days and it’s not in production yet. Perhaps inactivity ?

Maybe this is related:

I don’t seem to have logging set up very well and cannot see if that is the issue for me.