How to close an issue with a commit + push?

Account creation failed because the confirmation email took more than 3 hours to reach my inbox. Now I can’t even retry as you web site now thinks the user name (and email) is already taken.

I consider that a bug, possibly one with security implications: If the allotted time has passed without a confirmation, that user should be forgotten completely as if it never attempted to register. Indeed, because those unconfirmed users are kept, I could register humpteen bogus users that way and increase the size of your table at will… I can use a list of known mails and block the registration of other future legitimate users…

Saw a few of spam sign-ups yesterday. Dumped my database and, well, I’m at about 15MB with 87 users and 51 repos so I’m not too worried about it right now. Priorities ya know?

Mailgun reports 100% delivery success rate yesterday though I didn’t have any permanent failures. Just two complaints from users who’s emails were probably picked by someone trying to mess with them.

If you didn’t see the email arrive just let me know and I’ll purge the user so you may try again. I also have SSO with GitHub and users have reported it works well so you could try that too.

I did see the e-mail. Just that it arrived too late. I must say that yesterday evening I saw mails coming in that were sent in the morning… I suppose the problem is on my side (the mail).
The user is pcopissa at any rate.

1 Like

Ok, I think I have made some progress:

I created an account on + repository + one issue (#1).
I tried to clone the repository via SSH in GitExtension GUI, specifying URL This failed with:
FATAL ERROR: Disconnected: No supported authentication methods available (server sent: publickey)
fatal: Could not read from remote repository.

I then tried to clone the repository via HTTPS, which also failed with GitExtension Windows GUI client.(this time it complained about not finding a few DLLs and even when copied over, complained about some missing entry points)
I therefore cloned the repository via MSYS2 git.exe CLI. Specifically:
git clone ''
I committed + pushed with the usual three line commit message mentionned above ad nauseam (with fixes #1 as the third line)
This closed the issue.

The most significant difference here is the protocol: In all the tests mentionned above, I have used SSH + GitExtension with URL git@git.lan:p.copissa/test. And that worked (in the sense, I could clone, commit, push, but closing issues would fail)

So I tried using HTTPS and MSYS2 git.exe. Specifically:
git clone http://git.lan:3000/p.copissa/test.git
I then commited + pushed with the above-mentionned commit message.
The issue got closed.

Then I tried with SSH and the same MSYS2 git.exe (needed to export GIT_SSH environment to make that work with Putty’s plink.exe instead of ssh). Specifically:
git clone 'git@git.lan:p.copissa/test'
Then committed + pushed as above.
The issue remained open.

I have tried to create a Gitea user git and added it as a collaborator, specifying git as the committer.
None of this allowed to close the issue via commit over SSH.

Note that when pushing via HTTP, git.exe paused to asked me for a username and password. (Apparently this has to be a Gitea user). On the over hand, git.exe never paused when committing over SSH.

So at this point it seems it has something to do with using SSH.

This is on Gitea 1.5.2 (release) BTW.

1 Like

I have entered issue #5107 on Github

1 Like

TL;DR git issue went unresolved AFAICT but it appears to have been an environment issue, a good reason to prefer to use Docker in prod.

1 Like